by: CITRAWEB SOLUSI TEKNOLOGI, PT
Aturan | Tentang Kami | Kontak Kami

Kami tetap melayani pembelian secara online

Sehubungan dengan wabah COVID-19, kami tetap melayani pembelian barang secara online.

Nikmati ONGKOS KIRIM GRATIS untuk tujuan Pulau Jawa.

Untuk konsultasi, gunakanlah telp 0274-6059988 atau email/web. Kantor Yogyakarta beroperasi Senin - Jumat jam 09.00 - 17.00 WIB dan untuk sementara tidak melayani kunjungan konsultasi dan support.

Kunjungan dan Pengambilan Barang

Untuk sementara waktu PT Citraweb Solusi Teknologi tidak menerima kunjungan dalam bentuk apapun. Semua kegiatan yang berhubungan dengan konsultasi, RMA dan order dilakukan secara online.

Artikel

Installasi VyOS pada MikroBits Dinara

Senin, 14 Maret 2022, 09:33:00 WIB
Kategori: Fitur & Penggunaan

VyOS merupakan sistem operasi jaringan berbasis debian. VyOS ini gratis dan bisa digunakan pada mesin lokal maupun cloud.

VyOS memiliki beberapa fitur menarik seperti Routing (BGP IPv4 IPv6, OSPF v2 v3, RIP, RIPng, dan juga Policy Based Routing), VPN (IPsec, VTI, VXLAN, L2TPv3, L2TP/IPsec and PPTP servers, tunnel interfaces

(GRE, IPIP, SIT), OpenVPN, Wireguard), Firewall (Stateful firewalls, zone-based firewall, source dan destination NAT (one to one, one to many, many to many). Network services (DHCP DHCPv6 server dan relay, IPv6 RA, DNS forwarding, TFTP server, web proxy, PPPoE, NetFlow/sFlow sensor, QoS) dan juga Hight Availability (VRRP untuk IPv4 dan IPv6, kemampuan untuk mengeksekusi custom health checks dan transition scripts; ECMP, stateful load balancing).

VyOS ini memiliki sejarah yang lumayan keren, teman teman bisa membaca nya langsung pada halaman dokumentasi berikut https://docs.vyos.io/en/latest/introducing/history.html
 
Pada artikel sebelumnya (https://citraweb.com/artikel_lihat.php?id=481) kita juga pernah membahas tentang bagaimana cara menginstall OpenWRT pada MikroBits Ainos v3. Disana juga dijelaskan bahwa produk MikroBits Router sekarang tidak hanya bisa diinstall RouterOS MikroTik, namun bisa juga diinstall OS opensource lainnya sesuai kebutuhan di jaringan teman teman.

Untuk spesifikasi MikroBits Dinara v3 bisa teman teman lihat pada halaman berikut: https://citraweb.com/produk_lihat.php?id=919

Install VyOS pada MikroBits Dinara v3

Prasyarat

  1. Memiliki MikroBits Router / Server, pada percobaan kali ini kami akan menggunakan MikroBits Dinara v3
  2. Unduh file iso dari VyOS pada halaman berikut https://vyos.net/get/snapshots/
  3. Menyiapkan flashdisk dan burn menggunakan file iso yang sudah di unduh tadi.
  4. Monitor dan keyboard untuk installasi pada MikroBits Dinara v3 atau kabel konsol

Langkah langkah installasi VyOS

  1. Hubungkan vga pada monitor, keyboard, dan juga usb flashdisk berisi vyos kemudian nyalakan MikroBits Dinara v3, pada artikel ini kami menggunakan konsol untuk kebutuhan screen capture.
  2. Tekan "del" untuk masuk ke uefi
  3. Arahkan booting ke flashdisk berisi vyos tadi
  4. Pilih "live system"
  5. Login ke os menggunakan user dan password "vyos"
  6. Lakukan perintah "install image"
  7. Ada konfirmasi install, ketik "yes"
  8. Kebutuhan minimal penyimpanan vyos sebesar 2GB, ada konfirmasi konfigurasi partisi (default auto) kita menggunakan auto maka langsung tekan enter saja.
  9. Install image on [pilih di ssd 16gb] karena pada MikroBits Router sudah terdapat ssd 16gb di dalamnya.


  10. Untuk mengecek disk yang kita gunakan benar, bisa menggunakan perintah lsblk

  11. Konfirmasi install kita ketik "yes" lalu enter
  12. Konfirmasi seberapa besar partisi root, kami menggunakan default, langsung enter.
  13. Konfirmasi nama image, kami menggunakan nama default, langsung enter
  14. Konfirmasi copy konfigurasi, langsung enter
  15. Buat password untuk user vyos
  16. Pilih ssd 16gb untuk GRUB
  17. Jika sudah, lakukan reboot untuk melakukan booting vyos pada ssd

Konfigurasi dasar vyos

Setiap kita akan melakukan konfigurasi, kita harus masuk ke command "configure" dan diakhiri "commit" untuk menerapkan dan "save" untuk menyimpan kemudian "exit" untuk keluar dari mode konfigurasi.

MikroBits Dinara memiliki 8 ethernet, 8 sfp, dan 2 sfpplus dimana pembacaan nya dimulai dari sfp (eth0 - eth7) dilanjutkan sfpplus (eth8 & eth9) kemudian ethernet (eth10 - eth17).

Keterangan:
eth0-eth7 = sfp1 - sfp 8
eth8 & eth9 = sfpplus1 & sfpplus2
eth10 - eth17 = ethernet1 - ethernet8

Setelah mengetahui Ether nya kita bisa mulai untuk konfigurasi vyos. Kami akan mencoba untuk konfigurasi sederhana dimana vyos ini akan digunakan sebagai gateway internet dengan sumber internet dari eth17 (ether8) dan lan pada eth10, eth11, dan eth12 (dilakukan bridge).
  1. Atur IP Address WAN nya

                    
    
    
                      vyos@vyos:~$ configure
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set interfaces ethernet eth17 address
                      '192.168.77.213/23'
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# commit
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    vyos@vyos# save
                  

    Pada MikroBits Dinara v3, interface ethernet dibaca terakhir (ether10 - ether17), disini kami sambungkan ke ether8 secara fisik dan terbaca sebagai ether17.

  2. Aktifkan SSH untuk melakukan remote akses dari pc lain.

                    
    
    
                      vyos@vyos# set service ssh port 22
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# vyos@vyos# commit
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    vyos@vyos# save
                  

    Akses SSH
  3. Atur gateway dan dns agar router bisa internetan


                    
    
    
                      vyos@vyos# set protocols static route 0.0.0.0/0 next-hop
                      192.168.76.1
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set system name-server 192.168.76.1
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# commit
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    vyos@vyos# save
                  

    Coba lakukan ping

                    
    
    
                      vyos@vyos# ping citraweb.com
            
    
    
    PING citraweb.com (172.67.214.176) 56(84) bytes of data.
                      
    
    
                      
    
    64 bytes from 172.67.214.176 (172.67.214.176):
                      icmp_seq=1 ttl=55 time=24.0 ms
                      
    
    
                      64 bytes from 172.67.214.176 (172.67.214.176): icmp_seq=2
                      ttl=55 time=23.8 ms
                      
    
    
                      64 bytes from 172.67.214.176 (172.67.214.176): icmp_seq=3
                      ttl=55 time=23.9 ms
                      
    
    64 bytes from 172.67.214.176 (172.67.214.176):
                      icmp_seq=4 ttl=55 time=23.7 ms
                    
                  

  4. Konfigurasi jaringan LAN

                    
    
    
                      vyos@vyos# set interfaces bridge br1
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set interfaces bridge br1 member interface eth10
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set interfaces bridge br1 member interface eth11
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set interfaces bridge br1 member interface eth12
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set interfaces bridge br1 address 10.208.12.1/24
                      
    
    
                    
                    
    
    
                      
    
    vyos@vyos# commit
                      
    
    
                      
    
    
                        
    
    
                      
                      vyos@vyos# save
                    
                  

  5. Atur DHCP untuk client

                    
    
    
                      vyos@vyos# set service dhcp-server shared-network-name
                      vyos.local
                      
    
    
                      
    
    vyos@vyos# set service dhcp-server shared-network-name
                      vyos.local authoritative
                      
    
    
                      
    
    vyos@vyos# set service dhcp-server shared-network-name
                      vyos.local subnet 10.208.12.0/24 default-router 
                      10.208.12.1
                      
    
    
                      
    
    vyos@vyos# set service dhcp-server shared-network-name
                      vyos.local subnet 10.208.12.0/24 lease 3600
                      
    
    
                      
    
    vyos@vyos# set service dhcp-server shared-network-name
                      vyos.local subnet 10.208.12.0/24 range 1 start 10.208.12.2
                      
    
    
                      
    
    vyos@vyos# set service dhcp-server shared-network-name
                      vyos.local subnet 10.208.12.0/24 range 1 stop 10.208.12.254
                      
    
    
                      
    
    vyos@vyos# commit
                      
    
    
                      
    
    vyos@vyos# save
                    
                  

  6. Konfigurasi SNAT

                    
    
    
                      vyos@vyos# set nat source rule 1 source address
                      '10.208.12.0/24'
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set nat source rule 1 outbound-interface eth17
                      
    
    
                    
                    
    
    
                      
    
    
                    
                    
    
    
                      vyos@vyos# set nat source rule 1 translation address
                      'masquerade'
                      
    
    
                    
                    
    
    
                      
    
    vyos@vyos# commit
                      
    
    
                      
    
    
                        
    
    
                      
                      vyos@vyos# save
                    
                  

  7. Coba firewall filter

                    
    
    
                      vyos@vyos# set firewall name blokiripaddress description blokiripaddress
    
    
                      
    
    vyos@vyos# set firewall name blokiripaddress default-action accept
                      
    
    
                      
    
    vyos@vyos# set firewall name blokiripaddress rule 1 action drop
                      
    
    
                      
    
    vyos@vyos# set firewall name blokiripaddress rule 1 source address
                      10.208.12.0/24
                      
    
    
                      
    
    vyos@vyos# set firewall name blokiripaddress rule 1 destination
                      address 95.111.196.27
                      
    
    
                      
    
    vyos@vyos# set interfaces bridge br1 firewall in name
    blokiripaddress 
    
    
                      
    
    vyos@vyos# commit
                      
    
    
                      
    
    
                        
    
    
                      
                      vyos@vyos# save
                    
                  

    Melakukan pengujian dari client yang terhubung ke ether10 (br1) LAN

  8. API
    VyOS juga menyediakan API untuk bisa di akses dari aplikasi lain, ini memungkinkan teman teman untuk membuat webui sendiri untuk kebutuhan konfigurasi atau otomatisasi
Untuk contoh penggunaan lebih detail teman teman bisa membacanya pada dokumentasi dari vyos pada halaman berikut: https://docs.vyos.io/en/latest/introducing/about.html

Artikel ini dibuat pada 14 Maret 2022 menggunakan VyOS versi 1.3 dan 1.4



Kembali ke :
Halaman Artikel | Kategori Fitur & Penggunaan